blob: d640cbf3d722660a0026d8002ba83b1ceec5ea9a [file] [log] [blame]
Alexandre Lision81ecad62014-04-04 14:11:58 -04001# Copyright (c) 2014 David Sugar, Tycho Softworks.
2# This file is free software; as a special exception the author gives
3# unlimited permission to copy and/or distribute it, with or without
4# modifications, as long as this notice is preserved.
5#
6# This program is distributed in the hope that it will be useful,
7# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
8# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
9# PARTICULAR PURPOSE.
Emeric Vigier2f625822012-08-06 11:09:52 -040010
11Summary: A Common C++ Class Framework for RTP Packets
Alexandre Lision81ecad62014-04-04 14:11:58 -040012Name: ccrtp
13Version: 2.0.8
14Release: 0%{?dist}
Emeric Vigier2f625822012-08-06 11:09:52 -040015License: LGPL v2 or later
Alexandre Lision81ecad62014-04-04 14:11:58 -040016Group: System/Library
Emeric Vigier2f625822012-08-06 11:09:52 -040017URL: http://www.gnu.org/software/commoncpp/commoncpp.html
Alexandre Lisionddd731e2014-01-31 11:50:08 -050018Source0: ccrtp-%{version}.tar.gz
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
Alexandre Lision81ecad62014-04-04 14:11:58 -040020BuildRequires: ucommon-devel >= 6.0.0
Emeric Vigier2f625822012-08-06 11:09:52 -040021BuildRequires: pkgconfig
Emeric Vigier2f625822012-08-06 11:09:52 -040022BuildRequires: libgcrypt-devel
23BuildRequires: gcc-c++
24
25%description
Alexandre Lision81ecad62014-04-04 14:11:58 -040026GNU ccRTP is a generic, extensible and efficient C++ framework for
Emeric Vigier2f625822012-08-06 11:09:52 -040027developing applications based on the Real-Time Transport Protocol
28(RTP) from the IETF. It is based on Common C++ and provides a full
29RTP/RTCP stack for sending and receiving of realtime data by the use
30of send and receive packet queues. ccRTP supports unicast,
31multi-unicast and multicast, manages multiple sources, handles RTCP
32automatically, supports different threading models and is generic as
33for underlying network and transport protocols.
34
Alexandre Lision81ecad62014-04-04 14:11:58 -040035%package devel
Emeric Vigier2f625822012-08-06 11:09:52 -040036Group: Development/Libraries/C and C++
37Summary: Headers and static link library for ccrtp
Alexandre Lision81ecad62014-04-04 14:11:58 -040038Requires: %{name} = %{version}
39Requires: ucommon-devel >= 6.0.0
Emeric Vigier2f625822012-08-06 11:09:52 -040040Requires: libgcrypt-devel
Emeric Vigier2f625822012-08-06 11:09:52 -040041
Alexandre Lision81ecad62014-04-04 14:11:58 -040042%description devel
Alexandre Lisionddd731e2014-01-31 11:50:08 -050043This package provides the header files, link libraries, and
44documentation for building applications that use GNU ccrtp.
Emeric Vigier2f625822012-08-06 11:09:52 -040045
46%prep
Alexandre Lision81ecad62014-04-04 14:11:58 -040047%setup -q
Emeric Vigier2f625822012-08-06 11:09:52 -040048
Alexandre Lision81ecad62014-04-04 14:11:58 -040049%build
50%configure \
51 --with-pkg-config \
52 --disable-static \
53
54%{__make} %{?_smp_mflags}
Emeric Vigier2f625822012-08-06 11:09:52 -040055
56%install
Alexandre Lision81ecad62014-04-04 14:11:58 -040057%{__rm} -rf %{buildroot}
58%{__make} DESTDIR=%{buildroot} INSTALL="install -p" install
59%{__rm} %{buildroot}%{_libdir}/*.la
60%{__rm} -rf %{buildroot}/%{_infodir}
Emeric Vigier2f625822012-08-06 11:09:52 -040061
62%clean
63rm -rf %{buildroot}
64
Alexandre Lision81ecad62014-04-04 14:11:58 -040065%files
66%defattr(-,root,root,-)
Emeric Vigier2f625822012-08-06 11:09:52 -040067%doc AUTHORS COPYING ChangeLog README COPYING.addendum
68%{_libdir}/*.so.*
69
Alexandre Lision81ecad62014-04-04 14:11:58 -040070%files devel
71%defattr(-,root,root,-)
Emeric Vigier2f625822012-08-06 11:09:52 -040072%{_libdir}/*.a
73%{_libdir}/*.so
Alexandre Lisionddd731e2014-01-31 11:50:08 -050074%{_libdir}/*.la
Emeric Vigier2f625822012-08-06 11:09:52 -040075%{_libdir}/pkgconfig/*.pc
76%dir %{_includedir}/ccrtp
77%{_includedir}/ccrtp/*.h
78
Alexandre Lision81ecad62014-04-04 14:11:58 -040079%post -p /sbin/ldconfig
Emeric Vigier2f625822012-08-06 11:09:52 -040080
Alexandre Lision81ecad62014-04-04 14:11:58 -040081%postun -p /sbin/ldconfig
Emeric Vigier2f625822012-08-06 11:09:52 -040082
83%changelog
Alexandre Lisione41ecd42014-02-27 15:51:10 -050084* Thu Jan 06 2011 - Werner Dittmann <werner.dittmann@t-online.de>
Emeric Vigier2f625822012-08-06 11:09:52 -040085- Add Skein MAC authentication algorithm