blob: cb53fc0a5ff79a4c4bea2ac51433f8b8c884885b [file] [log] [blame]
Emeric Vigier2f625822012-08-06 11:09:52 -04001%{!?release: %define release 0}
2%{!?version: %define version 1.8.0}
3
4%define _libname libccrtp1
5%define _devname libccrtp-devel
6
7Summary: A Common C++ Class Framework for RTP Packets
8Name: libccrtp
9Version: %{version}
10Release: %{release}%{?dist}
11License: LGPL v2 or later
12Group: Development/Libraries/C and C++
13URL: http://www.gnu.org/software/commoncpp/commoncpp.html
14Source0: ccrtp-%{version}.tar.bz2
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildRequires: commoncpp2-devel >= 1.4.0
17BuildRequires: pkgconfig
18BuildRequires: libstdc++-devel
19BuildRequires: libgcrypt-devel
20BuildRequires: gcc-c++
21
22%description
23ccRTP is a generic, extensible and efficient C++ framework for
24developing applications based on the Real-Time Transport Protocol
25(RTP) from the IETF. It is based on Common C++ and provides a full
26RTP/RTCP stack for sending and receiving of realtime data by the use
27of send and receive packet queues. ccRTP supports unicast,
28multi-unicast and multicast, manages multiple sources, handles RTCP
29automatically, supports different threading models and is generic as
30for underlying network and transport protocols.
31
32%package -n %{_libname}
33Group: Development/Libraries/C and C++
34Summary: Runtime library for GNU RTP Stack
35Provides: %{name} = %{version}-%{release}
36
37%package -n %{_devname}
38Group: Development/Libraries/C and C++
39Summary: Headers and static link library for ccrtp
40Requires: %{_libname} = %{version}
41Requires: commoncpp2-devel >= 1.4.0
42Requires: libgcrypt-devel
43Provides: %{name}-devel = %{version}-%{release}
44
45%description -n %{_libname}
46This package contains the runtime library needed by applications that use
47the GNU RTP stack.
48
49%description -n %{_devname}
50This package provides the header files, link libraries, and
51documentation for building applications that use GNU ccrtp.
52
53%prep
54%setup
55%build
56%configure
57
58make %{?_smp_mflags} LDFLAGS="-s" CXXFLAGS="$RPM_OPT_FLAGS"
59
60%install
61
62%makeinstall
63rm -rf %{buildroot}/%{_infodir}
64
65%clean
66rm -rf %{buildroot}
67
68%files -n %{_libname}
69%defattr(-,root,root,0755)
70%doc AUTHORS COPYING ChangeLog README COPYING.addendum
71%{_libdir}/*.so.*
72
73%files -n %{_devname}
74%defattr(-,root,root,0755)
75%{_libdir}/*.a
76%{_libdir}/*.so
77%{_libdir}/*.la
78%{_libdir}/pkgconfig/*.pc
79%dir %{_includedir}/ccrtp
80%{_includedir}/ccrtp/*.h
81
82%post -n %{_libname} -p /sbin/ldconfig
83
84%postun -n %{_libname} -p /sbin/ldconfig
85
86%changelog
87* Tue Jan 06 2011 - Werner Dittmann <werner.dittmann@t-online.de>
88- Add Skein MAC authentication algorithm