Use dyfet github repo for libccrtp
diff --git a/jni/libccrtp/sources/ccrtp.spec b/jni/libccrtp/sources/ccrtp.spec
index 94beb47..d640cbf 100644
--- a/jni/libccrtp/sources/ccrtp.spec
+++ b/jni/libccrtp/sources/ccrtp.spec
@@ -1,26 +1,29 @@
-%{!?release: %define release 0}
-%{!?version: %define version 2.0.7}
-
-%define _libname libccrtp2
-%define _devname libccrtp-devel
+# Copyright (c) 2014 David Sugar, Tycho Softworks.
+# This file is free software; as a special exception the author gives
+# unlimited permission to copy and/or distribute it, with or without
+# modifications, as long as this notice is preserved.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
+# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
+# PARTICULAR PURPOSE.
 
 Summary: A Common C++ Class Framework for RTP Packets
-Name: libccrtp
-Version: %{version}
-Release: %{release}%{?dist}
+Name: ccrtp
+Version: 2.0.8
+Release: 0%{?dist}
 License: LGPL v2 or later
-Group: Development/Libraries/C and C++
+Group: System/Library
 URL: http://www.gnu.org/software/commoncpp/commoncpp.html
 Source0: ccrtp-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-BuildRequires: ucommon >= 5.0.0
+BuildRequires: ucommon-devel >= 6.0.0
 BuildRequires: pkgconfig
-BuildRequires: libstdc++-devel
 BuildRequires: libgcrypt-devel
 BuildRequires: gcc-c++
 
 %description
-ccRTP is a generic, extensible and efficient C++ framework for
+GNU ccRTP is a generic, extensible and efficient C++ framework for
 developing applications based on the Real-Time Transport Protocol
 (RTP) from the IETF. It is based on Common C++ and provides a full
 RTP/RTCP stack for sending and receiving of realtime data by the use
@@ -29,49 +32,43 @@
 automatically, supports different threading models and is generic as
 for underlying network and transport protocols.
 
-%package -n %{_libname}
-Group: Development/Libraries/C and C++
-Summary: Runtime library for GNU RTP Stack
-Provides: %{name} = %{version}-%{release}
-
-%package -n %{_devname}
+%package devel
 Group: Development/Libraries/C and C++
 Summary: Headers and static link library for ccrtp
-Requires: %{_libname} = %{version}
-Requires: ucommon-devel >= 5.0.0
+Requires: %{name} = %{version}
+Requires: ucommon-devel >= 6.0.0
 Requires: libgcrypt-devel
-Provides: %{name}-devel = %{version}-%{release}
 
-%description -n %{_libname}
-This package contains the runtime library needed by applications that use
-the GNU RTP stack.
-
-%description -n %{_devname}
+%description devel
 This package provides the header files, link libraries, and
 documentation for building applications that use GNU ccrtp.
 
 %prep
-%setup
-%build
-%configure
+%setup -q
 
-make %{?_smp_mflags} LDFLAGS="-s" CXXFLAGS="$RPM_OPT_FLAGS"
+%build
+%configure \
+    --with-pkg-config \
+    --disable-static \
+
+%{__make} %{?_smp_mflags}
 
 %install
-
-%makeinstall
-rm -rf %{buildroot}/%{_infodir}
+%{__rm} -rf %{buildroot}
+%{__make} DESTDIR=%{buildroot} INSTALL="install -p" install
+%{__rm} %{buildroot}%{_libdir}/*.la
+%{__rm} -rf %{buildroot}/%{_infodir}
 
 %clean
 rm -rf %{buildroot}
 
-%files -n %{_libname}
-%defattr(-,root,root,0755)
+%files
+%defattr(-,root,root,-)
 %doc AUTHORS COPYING ChangeLog README COPYING.addendum
 %{_libdir}/*.so.*
 
-%files -n %{_devname}
-%defattr(-,root,root,0755)
+%files devel
+%defattr(-,root,root,-)
 %{_libdir}/*.a
 %{_libdir}/*.so
 %{_libdir}/*.la
@@ -79,9 +76,9 @@
 %dir %{_includedir}/ccrtp
 %{_includedir}/ccrtp/*.h
 
-%post -n %{_libname} -p /sbin/ldconfig
+%post -p /sbin/ldconfig
 
-%postun -n %{_libname} -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
 
 %changelog
 * Thu Jan 06 2011 - Werner Dittmann <werner.dittmann@t-online.de>