blob: ab361bd50e2c758807350393778bf74f68c1169d [file] [log] [blame]
Emeric Vigier2f625822012-08-06 11:09:52 -04001#
2# spec file for package libccrtp (Version 1.6.2)
3#
4# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14
15# Please submit bugfixes or comments via http://bugs.opensuse.org/
16#
17
18# norootforbuild
19
20
21Name: libccrtp
22BuildRequires: commoncpp2-devel gcc-c++ openssl-devel pkgconfig
23Url: http://www.gnu.org/software/ccrtp/
24License: GPL v3 or later
25Group: System/Libraries
26BuildRoot: %{_tmppath}/%{name}-%{version}-build
27AutoReqProv: on
28Summary: A Common C++ Class Framework for RTP Packets
29Version: 1.8.0
30Release: 2
31Source0: ccrtp-%{version}.tar.bz2
32Source1: rpmlintrc
33# Patch1: ccrtp-gcc43.diff
34
35%description
36The ccrtp package offers a generic framework for sending and receiving
37real-time streaming data over UDP packets using sending and receiving
38packet queues.
39
40
41
42Authors:
43--------
44 David Sugar <dyfet@ostel.com>
45 Frederico Montesino Pouzols <p5087@quintero.fie.us.es>
46
47%package -n libccrtp1
48License: GPL v3 or later
49Group: System/Libraries
50Summary: A Common C++ Class Framework for RTP Packets
51Provides: ccrtp = %{version}
52Provides: %{name} = %{version}
53Obsoletes: ccrtp <= %{version}
54Obsoletes: %{name} <= %{version}
55
56%description -n libccrtp1
57The ccrtp package offers a generic framework for sending and receiving
58real-time streaming data over UDP packets using sending and receiving
59packet queues.
60
61
62
63Authors:
64--------
65 David Sugar <dyfet@ostel.com>
66 Frederico Montesino Pouzols <p5087@quintero.fie.us.es>
67
68%package devel
69License: GPL v3 or later
70Summary: Include-files and documentation for ccrtp
71Group: Development/Libraries/Other
72Requires: %{name} = %{version} commoncpp2-devel
73PreReq: %install_info_prereq
74
75%description devel
76This package contains files needed when developing applications using
77ccrtp
78
79
80
81Authors:
82--------
83 David Sugar <dyfet@ostel.com>
84 Frederico Montesino Pouzols <p5087@quintero.fie.us.es>
85
86%prep
87%setup -q -n ccrtp-%version
88# %patch1
89
90%build
91%configure --with-pic --disable-static --with-gnu-ld
92make
93
94%install
95make DESTDIR=$RPM_BUILD_ROOT install
96(cd doc; make DESTDIR=$RPM_BUILD_ROOT install)
97rm -f %{buildroot}%{_libdir}/libccrtp1.la
98
99%clean
100rm -rf $RPM_BUILD_ROOT;
101
102%post -n libccrtp1 -p /sbin/ldconfig
103
104%postun -n libccrtp1 -p /sbin/ldconfig
105
106%files -n libccrtp1
107%defattr(-,root,root,0755)
108%_libdir/libccrtp*.so.*
109
110%files devel
111%defattr(-,root,root,0755)
112%doc AUTHORS COPYING NEWS README TODO ChangeLog
113%_libdir/libccrtp*.so
114%_libdir/pkgconfig/libccrtp1.pc
115%dir %{_includedir}/ccrtp
116%{_includedir}/ccrtp/*.h
117%{_infodir}/ccrtp.info*
118
119%post devel
120%install_info --info-dir=%{_infodir} %{_infodir}/ccrtp.info.gz
121
122%postun devel
123%install_info_delete --info-dir=%{_infodir} %{_infodir}/ccrtp.info.gz
124
125%changelog