packaging: build again ring client binary package

Recent packaging changes removed the ring binary package from ring.cx
and replaced it by ring-all. This is because it doesn't make sense to
most end users to install daemon and client separately. However this
change has broken compatibility with the previous packaging policy, at
the very least because we didn't provide a transition package.

There are two solutions:
1. Provide a transition package
2. Build ring binary package again

Both should work well but 2. has better compatibility with official
Debian/Ubuntu packaging so we opt for this one.

Change-Id: I556ae580126038de7077f91b137adbf1046d59e4
diff --git a/packaging/rules/debian/rules b/packaging/rules/debian/rules
index 8bcdbf3..7128192 100755
--- a/packaging/rules/debian/rules
+++ b/packaging/rules/debian/rules
@@ -14,6 +14,7 @@
 
 # Binary package names
 RING_ALL_IN_ONE_PKG_NAME="ring-all"
+RING_CLIENT_PKG_NAME="ring"
 RING_DAEMON_PKG_NAME="ring-daemon"
 
 %:
@@ -144,6 +145,23 @@
 	rm -rfv $(CURDIR)/debian/$(RING_DAEMON_PKG_NAME)/usr/lib/*.a
 	rm -rfv $(CURDIR)/debian/$(RING_DAEMON_PKG_NAME)/usr/lib/*.la
 
+	#########################
+	## Ring client install ##
+	#########################
+
+        ## LibRingClient
+	cd lrc/build && make DESTDIR=$(CURDIR)/debian/$(RING_CLIENT_PKG_NAME) install
+	rm -rfv $(CURDIR)/debian/$(RING_CLIENT_PKG_NAME)/usr/include
+
+	# This is a symlink, should be in -dev package
+	rm -v $(CURDIR)/debian/$(RING_CLIENT_PKG_NAME)/usr/lib/libringclient.so
+
+	# cmake files
+	rm -rfv $(CURDIR)/debian/$(RING_CLIENT_PKG_NAME)/usr/lib/cmake
+
+        ## GNOME client
+	cd client-gnome/build && make DESTDIR=$(CURDIR)/debian/$(RING_CLIENT_PKG_NAME) install
+
 	######################
 	## Ring AiO install ##
 	######################