packaging: configure with --disable-shared

configure.ac in the daemon was patched to properly generate a .so
which is the default in auto tools; however we don't want to ship
a .so and we also want to link to libring statically, so
we run configure with --disable-shared

Change-Id: I49d581c9176049385e0f42dad27a25ffcd172d8a
Tuleap: #699
diff --git a/packaging/rules/debian/rules b/packaging/rules/debian/rules
index f2f9b6a..46b0f24 100755
--- a/packaging/rules/debian/rules
+++ b/packaging/rules/debian/rules
@@ -49,7 +49,8 @@
 	cd daemon && \
 		./autogen.sh && \
 		./configure \
-				--prefix=/usr
+				--prefix=/usr \
+				--disable-shared
 
 	#############################
 	## libringclient configure ##