Debian packaging fixes

This imports some of the changes made in the official Debian packaging
repository: https://anonscm.debian.org/cgit/pkg-voip/ring.git

- Don't run containers in interactive mode, which would require a TTY

- Build LRC with Debug symbols

- Build with V=1 to allow parsing logs

- Reorganize dependencies

- Try fetch-all three times before giving up

- Removed ubuntu15.04 references

Tuleap: #858
Change-Id: If0a81b15230a31d120982e113e695443262568e3
diff --git a/packaging/rules/debian/rules b/packaging/rules/debian/rules
index 6613410..e2c81fb 100755
--- a/packaging/rules/debian/rules
+++ b/packaging/rules/debian/rules
@@ -46,14 +46,14 @@
 				--disable-vorbisenc \
 				--disable-speex \
 				--disable-sndfile \
+				--disable-gsm \
 				--disable-speexdsp && \
 		make list && \
-		make -j1
+		make -j1 V=1
 	cd daemon && \
 		./autogen.sh && \
 		./configure \
-				--prefix=/usr \
-				--without-iax
+				--prefix=/usr
 
 	#############################
 	## libringclient configure ##
@@ -64,7 +64,7 @@
 		cmake  \
 			-DRING_BUILD_DIR=$(CURDIR)/daemon/src \
 			-DCMAKE_INSTALL_PREFIX=/usr \
-			-DENABLE_VIDEO=true \
+			-DCMAKE_BUILD_TYPE=Debug \
 			..
 
 	############################
@@ -84,18 +84,18 @@
 	#######################
 	## Ring Daemon build ##
 	#######################
-	cd daemon && make -j$(NO_CPUS)
+	make -C daemon -j$(NO_CPUS) V=1
 	pod2man daemon/man/dring.pod > daemon/dring.1
 
 	#########################
 	## libringclient build ##
 	#########################
-	cd lrc/build && make -j$(NO_CPUS)
+	make -C lrc/build -j$(NO_CPUS) V=1
 
 	########################
 	## gnome client build ##
 	########################
-	cd client-gnome/build && make LDFLAGS="-lpthread" -j$(NO_CPUS)
+	make -C client-gnome/build LDFLAGS="-lpthread" -j$(NO_CPUS) V=1
 
 override_dh_auto_clean:
 	################################