Build jami-libclient (LRC) with libwrap enabled.

* packaging/rules/debian/rules (override_dh_auto_configure): Move
recipes to ...
(override_dh_auto_configure_build): ... here.  This is necessary as
the LRC now must find the share library of the daemon, hence it must
be built before the LRC configuration occurs.
<-DENABLE_LIBWRAP=true>: New option when configuring the LRC.
* packaging/rules/rpm/jami-libclient.spec (%build): Likewise.
* scripts/install.sh (lrc_cmake_flags): Likewise.
(OSTYPE): Remove variable.
(sharedLib): Remove variable.  The Jami daemon shared library is
needed when dynamically linking against it when libwrap is enabled.
* packaging/rules/rpm/jami-daemon.spec (%build): Drop the --disable-shared
option.
(%files): Register the libring.so dynamic library.
* packaging/rules/debian/rules (override_dh_auto_configure): Drop the
--disable-shared option.

GitLab: https://git.jami.net/savoirfairelinux/jami-packaging/-/issues/101
Change-Id: Id1acaaf15a0f3d561c73bf34dde48f4eaf058eed
diff --git a/packaging/rules/debian/rules b/packaging/rules/debian/rules
index 276f2f8..a1fd53b 100755
--- a/packaging/rules/debian/rules
+++ b/packaging/rules/debian/rules
@@ -55,9 +55,9 @@
 	dh $@
 
 override_dh_auto_configure:
-	###########################
-	## Daemon configure      ##
-	###########################
+
+override_dh_auto_build:
+	# Daemon contribs build + configure
 	mkdir -p daemon/contrib/native
 	cd daemon/contrib/native && \
         ../bootstrap \
@@ -79,64 +79,41 @@
 	cd daemon && \
 	./autogen.sh && \
 	./configure \
-          --disable-shared \
 	  --prefix=/usr \
 	  --host=${HOST_ARCH}
 
-	#############################
-	## libringclient configure ##
-	#############################
+	# Daemon build
+	make -C daemon -j$(NO_CPUS) V=1
+	pod2man daemon/man/jamid.pod > daemon/jamid.1
+
+	# Libringclient configure
 	cd lrc && \
 	mkdir build && \
 	cd build && \
 	cmake  \
 	  -DRING_BUILD_DIR=$(CURDIR)/daemon/src \
-	  -DENABLE_LIBWRAP=false \
+	  -DENABLE_LIBWRAP=true \
 	  -DCMAKE_INSTALL_PREFIX=/usr \
 	  -DCMAKE_INSTALL_LIBDIR=lib \
 	  $(CMAKE_OPTIONS) ..
 
-	############################
-	## gnome client configure ##
-	############################
-	cd client-gnome && \
-		mkdir build && \
-		cd build && \
-		cmake \
-			-DCMAKE_INSTALL_PREFIX=/usr \
-			-DCMAKE_INSTALL_LIBDIR=lib \
-			-DLibRingClient_PROJECT_DIR=/$(CURDIR)/lrc \
-			-DGSETTINGS_LOCALCOMPILE=OFF \
-			$(CMAKE_OPTIONS) \
-			..
-
-	#########################
-	## qt client configure ##
-	#########################
-	# needs to be done after lrc is built; see below
-
-	dh_auto_configure
-
-override_dh_auto_build:
-	#######################
-	## Daemon build      ##
-	#######################
-	make -C daemon -j$(NO_CPUS) V=1
-	pod2man daemon/man/jamid.pod > daemon/jamid.1
-
-	#########################
-	## libringclient build ##
-	#########################
+	# libringclient build
 	make -C lrc/build -j$(NO_CPUS) V=1
 
-	########################
-	## gnome client build ##
-	########################
+	# GNOME client configure
+	cd client-gnome && \
+	  mkdir build && \
+	  cd build && \
+	  cmake -DCMAKE_INSTALL_PREFIX=/usr \
+		-DCMAKE_INSTALL_LIBDIR=lib \
+		-DLibRingClient_PROJECT_DIR=/$(CURDIR)/lrc \
+		-DGSETTINGS_LOCALCOMPILE=OFF \
+		$(CMAKE_OPTIONS) ..
+
+	# GNOME client build
 	make -C client-gnome/build LDFLAGS="-lpthread" -j$(NO_CPUS) V=1
 
-	###################################
-	## qt client configure and build ##
-	###################################
+	# Qt client configure and build
 	cd client-qt && \
 	mkdir build && \
 	cd build && \