packaging: renaming packages from ring to jami

This commit rename the tarball, debian, ubuntu and fedora packages.

This commit also modify the debian post install script to add support
our repositories for Debian 10 and Ubuntu 18.10 and 19.04 and create
transition packages to ensure a proper nama transition in debian based
distributions.

Warning: when using reprepo to add the ring transition deb package
this get into pool/main/j/jami. for now we think is a reprepo error
because reads the Source: instead of Package: field.

Change-Id: I47449a79c1a8bfd6ee0f3ffed618886f1dc1645a
diff --git a/packaging/rules/debian/rules b/packaging/rules/debian/rules
index 7b289ef..f1fbab0 100755
--- a/packaging/rules/debian/rules
+++ b/packaging/rules/debian/rules
@@ -13,9 +13,9 @@
 endif
 
 # Binary package names
-RING_ALL_IN_ONE_PKG_NAME="ring-all"
-RING_CLIENT_PKG_NAME="ring"
-RING_DAEMON_PKG_NAME="ring-daemon"
+RING_ALL_IN_ONE_PKG_NAME="jami-all"
+RING_CLIENT_PKG_NAME="jami"
+RING_DAEMON_PKG_NAME="jami-daemon"
 
 %:
 	dh $@
@@ -146,7 +146,7 @@
 	rm -rfv $(CURDIR)/debian/$(RING_DAEMON_PKG_NAME)/usr/lib/*.la
 
 	#########################
-	## Ring client install ##
+	## Jami client install ##
 	#########################
 
         ## LibRingClient
@@ -161,10 +161,10 @@
 
         ## GNOME client
 	cd client-gnome/build && make DESTDIR=$(CURDIR)/debian/$(RING_CLIENT_PKG_NAME) install
-	ln -sf /usr/bin/jami $(CURDIR)/debian/ring/usr/bin/ring.cx
+	ln -sf /usr/bin/jami $(CURDIR)/debian/jami/usr/bin/ring.cx
 
 	######################
-	## Ring AiO install ##
+	## Jami AiO install ##
 	######################
 
         ## daemon
@@ -185,7 +185,7 @@
 
         ## GNOME client
 	cd client-gnome/build && make DESTDIR=$(CURDIR)/debian/$(RING_ALL_IN_ONE_PKG_NAME) install
-	ln -sf /usr/bin/jami $(CURDIR)/debian/ring-all/usr/bin/ring.cx
+	ln -sf /usr/bin/jami $(CURDIR)/debian/jami-all/usr/bin/ring.cx
 
 tmpdir:= $(shell mktemp -d)
 workdir:= $(shell pwd)
@@ -194,22 +194,22 @@
 
 # Repacks the tarball with contrib tarballs unpacked.
 get-orig-source:
-	# Download ring tarball
+	# Download jami tarball
 	if [ -n "$$GET_ORIG_SOURCE_OVERRIDE_USCAN_TARBALL" ]; then \
 	    mv $$GET_ORIG_SOURCE_OVERRIDE_USCAN_TARBALL ${tmpdir}; \
 	else \
 	    uscan --rename --destdir=${tmpdir} --download-version ${version_to_download} ;\
 	fi
 
-	# Unpack ring tarball
+	# Unpack jami tarball
 	tar -C ${tmpdir} -xf ${tmpdir}/*.tar.gz
 
 	# Remove original tarball
 	rm ${tmpdir}/*.tar.gz
 
 	# Unpack all of the orig tarballs into tarballs-unpacked
-	if [ -d "${tmpdir}/ring/" ]; then \
-		mv ${tmpdir}/ring/ ${tmpdir}/ring-project/; \
+	if [ -d "${tmpdir}/jami/" ]; then \
+		mv ${tmpdir}/jami/ ${tmpdir}/ring-project/; \
 	fi
 	mkdir ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked
 	for i in `find ${tmpdir}/ring-project/daemon/contrib/tarballs/ -name "*.tar.*"`; do \
@@ -243,7 +243,7 @@
 	rm -rf ${tmpdir}/ring-project/daemon/contrib/tarballs
 
 	# Create the new tarball
-	cd ${tmpdir} && tar -czf ${workdir}/ring_${version_to_download}~dfsg1.orig.tar.gz ring-project
+	cd ${tmpdir} && tar -czf ${workdir}/jami_${version_to_download}~dfsg1.orig.tar.gz ring-project
 
 	# Clear the temp dir
 	rm -rf ${tmpdir}